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OCS & MOTD Editor Suite 

Software Installation and Operation 

Run the setup/installer from your installation CD or FTP site. 
 
Note:  Everbrite software can run in a Microsoft Windows "limited" user account, but 
administrator privileges are required for installation. 

Initial Software Configuration 

After software installation, the OCS Editor program will 
start automatically or click Start > Programs > Everbrite 
OCS Editor Suite > OCS Editor. 
 
If the software is not yet configured, a popup window 
will appear (see figure right) informing the user that the 
OCS Update Utility needs to run to define connections.  This utility will configure how the 
software will communicate with the OCS. 
 
Click OK to load the OCS Update Utility program. 
 

Connection Setup Wizard 

Serial or network connections can easily be defined by using the Connection Setup Wizard.  
The wizard will start automatically if no connections are defined or click the “Connection 
Setup Wizard” button on the Settings tab. 
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Defining Serial Connections 

Start the Connection Setup Wizard, choose “USB / Serial 
Connection” and then click “Next”. 
 
Use one of the following connection methods: 

1. Use a USB cable to connect the converter’s "USB" port to 
the PC’s USB port 

2. Use a serial cable to connect the converter’s "From PC" 
port to the PC’s serial port or USB-serial adapter 

Make sure that any the drivers are loaded for any USB devices in use.  Click “Next. 
 

 
 
Click “Scan for Ports” to scan for available serial ports on the computer.  If everything is 
connected and functioning correctly, an OCS will be detected on a port.  Click this port and 
then click “Next”.  To create a connection for this OCS, click “Finish”. 
 

Defining Network Connections 

Start the Connection Setup Wizard, choose “Network 
Connection” and then click “Next”. 
 
Click “Scan for OCSs” to scan the local area network for 
connected OCSs.  Click the OCS in the list that is to be 
modified or selected and then click “Next”. 
 
Note: When an OCS is selected, click “Identify OCS” to popup an identifying message on 
the screen outside.  This is useful for identifying two OCSs with similar settings; the units 
can then be renamed with more descriptive names. 
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The network settings on the selected OCS can now be modified.  Make any changes 
necessary and then click “Next”.  If changes have been made, the wizard will indicate 
whether the changes were successful.   
 

 
 
 
To create a connection for 
this OCS, click “Finish”. 

 

 
 

 
 

Setting the OCS Date and Time 

When uploading new configurations/images using the OCS Editor, the date/time on the 
OCS will automatically be changed to the date/time of the host computer (where the 
software is running). 
 

To change the date/time manually, run the OCS 
Update Utility program by clicking Start > 
Programs > Everbrite OCS Editor Suite > OCS 
Update Utility.  When the program is running, 
click on the "Date/Time" tab (see figure right). 
 
To see what time the OCS is set to, click the 
"Refresh" button.  The OCS date/time will be 
displayed in the "OCS Date/Time" box in red. 
 
To set a new date/time, click either "Sync OCS 

Date/Time with this Computer" or "Set OCS Date/Time to:" and then manually select the 
new date/time using the controls.  Once you pick an option, click the "Set OCS Date/Time" 
button to perform the task. 
 
This concludes the installation of the back office software.  For further details on use 
of the software, continue below. 
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OCS Editor Operational Details 

This application is used to determine the way your OCS looks to the customer and its 
configuration.  The number of dayparts, images shown at slideshow, order pad color 
scheme, scrolling text and much more are the settings that can be set through the Editor.  
Once the look is set up, images and setup files are saved and sent to the OCS. 

How to use the Editor 

There are two types of tabs to work from: a General settings tab and five Daypart settings 
tabs.  Dayparts are simply periods of time which contain a common theme (example: 
breakfast, lunch, dinner).  Here are the basic features of each type of tab: 
 
General Tab settings  

 Update Configuration and Images – This section loads a new configuration (settings 
& images) into the Editor software.  The choices are to download the latest factory 
configuration from Everbrite (requires a configured internet connection) or to revert the 
configuration back to the shipping installed defaults. 

  Lookup Table file – This is a 
file that can link short POS item 
descriptors to longer, more 
customer friendly descriptors.  
For example if your POS uses 
“HB” as a descriptor, the table 
can substitute the words “Single 
Hamburger” to the customer.  
Everbrite can assist in creating 
this file for your specific 
requirements. 

 Popup Table file – This type of 
table allows for sophisticated 
pop up graphics like suggestive 
selling, last item ordered 
images and 
condiments/selections images.  Everbrite can assist in creating these files for your 
specific requirements. 

 POS Type – Use the drop down selector to choose the POS system you have.  Refer to 
your POS supplier to make sure it is sending out data to the OCS. 

 Greeting Display Time – If a greeting display is set from any of the daypart tabs, it is 
held for the number of seconds set in this field, after a car trips the loop detector.  If set 
to 0, then the image stays up until the order starts. 

 Closing Display Time – This is the amount of time in seconds that the closing image is 
held on the screen. 

 End of Order Delay – This is the amount of time in seconds that the order pad will hold 
after the order has been totaled. 
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 Tax and Total Formats – This is a format for how the numbers look on the order pad.  
If these need to be reset, use Edit > Restore Formats. 

 Tax and Total Captions – These are the actual words placed in front of the amounts 
on the order pad. 

  OCS Display Language – The language which the OCS will display text in.  

 
 Daypart Tabs  
Click on the first daypart tab to 
start.  This tab is where the look of 
the OCS is developed.  The look 
can be changed by daypart time 
periods (breakfast, lunch, dinner, 
etc.).  The time of the daypart is set 
and images and colors are 
selected.  Up to five images can 
cycle for the slideshow for each 
daypart and up to five dayparts can 
be defined.  Each set of dayparts 
defines a 24-hour period. 
 
Note the color-coded daypart at 
a glance at the lower right corner 
of the screen.  This allows you to see what time of day each daypart falls into and 
how many dayparts are set by color. 
 

 Start Time – This is the time of day this daypart will begin.  It will continue until another 
daypart is set or the day starts over. 

 Delete Daypart button – You must have at least one daypart but if you want to remove 
a complete daypart setup, use this button. 

 Greeting screen – This is a screen that interrupts the slideshow when a car pulls up to 
the drive thru.  This holds for the amount of time set on the General tab.  You can load 
an image with or without overlay text or a solid color with text overlay.  Enter the text in 
the box next to the text color button.  Note: You must have the converter box 
connected to an extra output from the drive thru microphone loop detector to use 
this feature. 

 Closing screen – This screen is displayed after the order is 
totaled.  You can set an image to display or use a solid color.  
To have the order total display, use the Total Box button to 
select exactly where on the image you want the total amount 
to be displayed.  If you want text to display in front of the 
amount, enter it in the box next to the text color button.  To 
change the total font color, use the text color button. 

 Order pad – This is where the customer’s order is displayed.  
You can set the background color and descriptor (alpha) text 
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color and numeral colors.  Use colors with high contrast like black and white for best 
readability.  You can set a single image or image slideshow on the order pad (see figure 
right).  If the image is 1024x768 pixels in size, it will be displayed behind the text and 
cover the entire order pad.  If you use an image that’s between 100 and 614 pixels wide 
by 768 pixels high, the image will be displayed on the right side of the screen and the 
order text will automatically scale to the remaining area. 

 Scrolling text – Scrolling text can be set on the order pad or on a slideshow with only 
one image.  Use the radio button to select which scrolling text to enter (Pad or Slide).  
Enter the text to scroll across the bottom of the screen in the box provided.  You can 
also display today or tomorrow's Message of the Day in the text box by clicking Edit > 
Insert Today’s Message or Insert Tomorrow’s Message.  Set the text and background 
colors using the appropriate buttons.  Use high contrast colors like black and white.  Set 
the speed using the slider bar (slow 1, medium 2 or fast 3). 

 Slides 1 - 5 – Select an image with or without overlay text or a solid color with overlay 
text.  Select the hold time in seconds for each image in the slide show.  If slowdown in 
the drive thru during busy times is a concern, use just a single image for those busy 
times. You can also display today or tomorrows Message of the Day in the text box by 
clicking Edit > Insert Today’s Message or Insert Tomorrow’s Message. 

 
Add more Dayparts as Needed 
Click on the next tab and click the "Add Daypart" button.  
Note that only the next unused daypart can be added 
(see figure right). 
 
File Menu  

 File > Save – Saves any changes that are made to 
the configuration 

 File > Download – Sends the configuration to the OCS 

 File > Exit - Closes the application 

Edit Menu 

 Edit > Insert POS Message – Inserts a variable which will be replaced by a POS-
transmitted greeting message (this option appears only with certain POS systems). 

 Edit > Insert Linefeed – Use this to skip to a new line when editing slide overlay text 

 Edit > Insert Today’s Message – Inserts a variable which will be replaced by today’s 
Message of the Day (see Building Messages in the OCS Editor). 

 Edit > Insert Tomorrow’s Message – Inserts a variable which will be replaced by 
tomorrow’s Message of the Day (see Building Messages in the OCS Editor). 

 Edit > Restore Formats – Use this on the General tab to set the Tax and Total 
formats to the default settings 

Setup Menu 

 Setup > Update OCS Software – Checks the OCS software to make sure that it is 
compatible with the current OCS Editor feature-set and updates if needed. 
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 Setup > Modify OCS Connections – Loads the OCS Update Utility which is used to 
define all connections (serial, network and 
modem) to the OCS. 

 Setup > Editor Options – The Download Mode 
options can save time updating the OCS.  "All" 
will send the entire configuration to the OCS 
every time a change is made.  "All Next Time" will 
send the entire configuration during the next 
download and then only changes after that.  "Only 
Changes" will send only the changes that have 
taken place between download sessions.  Note:  
It is highly recommended to keep this setting 
at “All”. 

Help Menu 

 Help > Check for Updates… – Checks for software updates via the Web.  Note: The 
application will automatically check for updates daily without user intervention. 

 Help > About – Displays information about the application 

 
Sending Changes to the OCS 
Once changes to the General and Daypart tabs are complete, the changes need to be sent 
to the OCS.  To save the changes to disk, move the mouse to the menu bar and click File > 
Save.  To send those changes out to the OCS click File > Download.  Depending on the 
number of images and the connection type, the file transfer will take a while to complete (a 
progress bar will show the relative progress of each file). 
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MOTD Editor Operational Details 

The Message of the Day (MOTD) application allows you to define a set of changing, daily 
messages which can be displayed on the OCS.  Specifically, the messages can appear: 

 In front of the solid background color of a slide or greeting screen 

 In front of the image used for a slide or greeting screen 

 Inserted into the scrolling text of the orderpad or slide 
The user has access to both today’s message as well as tomorrow’s message. 
 

Building Messages in the OCS Editor 

When the OCS Editor application is 
running and the user clicks in a text 
box where a message can be 
inserted (see bullets above and figure 
right), the Insert Today’s Message 
and Insert Tomorrow’s Message 
choices will be enabled in the Edit 
menu. 
 
When the today’s message or 
tomorrow’s message is inserted into a 
text box, the characters %MOTD% or 
%MOTD+1% (respectively) will 
appear.  These phrases can be 
thought of as “fields” or “variables” 
that will be replaced with the dated 
messages built using the MOTD Editor later. 
 
Note:  After MOTD messages are set, make sure to download changes to the OCS. 
 
 

 How to use the MOTD Editor 

This application actually builds the dated 
message database which gets stored on the 
OCS.  These messages are inserted into the 
MOTD variables defined above. 
 
The first thing to do when building a new 
database is set the Start Date which defines the 
starting date of the database.  Once the 
database is started, this option doesn’t appear (it 
appears to the right for clarity). 
 
The Turnover Time defines the time at which the messages will switch from one day to the 
next.  This is usually set at midnight or set to the store closing time if after midnight. 
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The Default message is the message that will be used if the OCS encounters a date where 
there is no message defined.  For example, if the specials for August are in the database 
on the OCS and the actual date is in October, the OCS uses this default message. 
 
 
The Message box contains the message that can be associated with a date and is used 
with other controls to perform various functions: 

1. Change Message – Change a day’s message by clicking the day in the left window, 
typing the new message in the Message box (or copying it from the list) and hitting 
this button.  If the day in the left window is double-clicked, its message will appear in 
the Message box for editing. 

2. Insert Day – Insert a day before another day in the database by clicking the day in 
the left window, typing a message in the Message box (or copying it from the list) 
and hitting this button. 

3. Append Day – Append a day onto the end of the database by typing a message in 
the Message box (or copying it from the list) and hitting this button. 

4. Delete Day – Delete a day by clicking the day in the left window and hitting this 
button. 

5. Copy Message from List – This button will bring up a predefined list of messages 
that the user can create and edit.  When a message in the list is selected, it will 
appear in the Message box where the above operations can be performed (see 
Using the Message List Below for details). 

 

Using the Message List  

The message list is a predefined list of messages that 
were either installed with the software and/or that the 
user can create and edit.  This feature makes building a 
database faster since the user doesn’t have to type 
messages in each time – just copy them from the list. 
 
Select a Message - To copy a message back to the 
main editor, click a message in the left window and 
click OK (or hit Enter) or just double click the message. 
 
Change a Message – To change a message, click a 
message in the left window and click Change.  When 
the message is complete, hit Enter. 
 
Add a Message – To add a message to the list, click 
the Add button and type in a message.  Hit Enter when 
the message is complete. 
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Delete a Message – To delete a message, click the message in the left window and click 
the Delete button.  
 
Here are the menu options in the MOTD Editor: 
 
File Menu  

 File > Print – Prints the message database 

 File > Download – Sends the message database to the OCS 

 File > Exit - Closes the application 

View Menu 

 View > Font Smaller – Reformat the window with a smaller font 

 View > Font Larger – Reformat the window with a larger font 

 View > Calendar – View and edit the message database using a calendar format 

Message Menu (these functions are identical to the buttons in the main window) 

Setup Menu 

 Setup > Editor Options – Options such as whether the OCS time is synchronized 
during a download and how to delete obsolete database history. 

Help Menu 

 Help > Check for Updates… – Checks for software updates via the Web.  Note: The 
application will automatically check for updates daily without user intervention. 

 Help > About – Displays information about the application 

 
 
Sending the Database to the OCS 
The database must reside on the OCS in order to be used.  To send the database out to 
the OCS click File > Download. 
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OCS Update Utility Operational Details 

This program handles the actual transfer of files and commands to the OCS.  It is invoked 
by the OCS Editor or an individual (primarily a service technician) since all settings can be 
set on the OCS by using the Editor application.  The OCS clock can be set through the 
OCS Update program.  OCS Update must be run first on a new install to set up how to 
communicate with the OCS. 
 
Settings Tab 
There are three different Types of connections 
that can be used to talk to the OCS: Serial, 
Network and Modem.  All connections can be 
given arbitrary Names to define the connection 
(like OCS East or Main OCS).  Serial 
connections require a COM port, Network 
connections require a Host Name and Modem 
connections require a COM port and Phone 
Number. 
 
Multiple connections can be defined for quick 
access using the right and left arrow buttons.  The current connection will be displayed near 
the top of the screen (see figure right showing connection 1 of 1, named "OCS1" as a 
COM1 Serial connection). 
 
Connections can be added automatically by using the “Connection Setup Wizard” button.  
They can also be added or deleted manually by using the "Add" and "Delete" buttons.  
While editing a connection, these two buttons will change to "Accept" (save changes and 
exit edit mode) and "Reject" (discard changes and exit edit mode). 
 
Date/Time Tab 
This tab allows you to set and get the OCS date 
and time.  To see the current date and time of 
the OCS, click the "Refresh" button.  To set the 
OCS to the current time of the PC the update 
application is running on select “Set OCS to 
Local System Date/Time” and then click "Set 
OCS Time/Date".  Alternately, if you want to set 
the sign manually select “Set OCS Date/Time 
to:” and enter the appropriate date/time and then 
click "Set OCS Time/Date". 
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File Updates Tab 
This tab allows you to browse the PC to locate 
files to send to the OCS.  This application is only 
used in trouble shooting or other updating 
instances.  It is best to let the editor handle how 
and when updates are sent to the OCS. 
 
Use the drive, folder and file controls to navigate 
to the file that needs to be transferred to the 
OCS.  Click on the file and click then the "Send 
File(s) to OCS" button. 

 
 
Diagnostics Tab – System Information 
This tab allows you to check various hardware 
related information about the OCS.  Click on any 
of the "Get" buttons to return information on that 
particular piece of hardware.  This information 
may be helpful to Everbrite Technical Support 
personnel. 
 
 
 
 

 
Diagnostics Tab – Software Configuration 
This tab allows you to check various software 
related information about the OCS.  Click on any 
of the "Get" buttons to return information on that 
particular piece of hardware.  This information 
may be helpful to Everbrite Technical Support 
personnel. 
 
 
 

 
 
Diagnostics Tab – Controller Feedback 
This tab allows you to check various hardware 
related information and run diagnostics tests on 
the OCS.  Click on any of the "Get" or "Test" 
buttons to return information on that particular 
piece of hardware.  This information may be 
helpful to Everbrite Technical Support personnel. 
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Diagnostics Tab – Network Settings 
This tab allows you to get and set all network-
related settings on the OCS.  Click on any of the 
"Get" buttons to return information on that 
particular setting.  The factory defaults of an 
OCS are generally a Network Name of "OCS" 
and DHCP enabled. 
 
 
 
 

 
Note: Generally, it is much easier to use the Connection Setup Wizard from the 
Settings tab to modify network settings.  Using the wizard is the recommended 
method for network setting modification. 
 
To manually change the current OCS’s network settings, type a valid (computer) name and 
choose the DHCP state.  If DHCP is disabled, a static IP Address and Subnet IP Mask 
need to both be defined.  When all settings are verified, click “Program current OCS with 
above Settings” to send them to the OCS. 
 
 
Program Updates 
Right-click on any tab to check for software updates via the 
Web.  Note: The application will automatically check for 
updates daily without user intervention. 
 


